2020
09-03

openwrt编译出现错误opkg_install_cmd: Cannot install packag

But that file is already provided by package

编译openwrt固件出现opkg_install_cmd: Cannot install package错误

Collected errors:
* check_data_file_clashes: Package luci-mod-admin-full wants to install file /opt/svnworking/A1905_Openwrt_4G/source/master/build_dir/target-mipsel_24kc_musl/root-ramips/usr/lib/lua/luci/controller/admin/index.lua
But that file is already provided by package * luci-base
* check_data_file_clashes: Package luci-mod-admin-full wants to install file /opt/svnworking/A1905_Openwrt_4G/source/master/build_dir/target-mipsel_24kc_musl/root-ramips/usr/lib/lua/luci/controller/admin/network.lua
But that file is already provided by package * luci-mod-network
* check_data_file_clashes: Package luci-mod-admin-full wants to install file /opt/svnworking/A1905_Openwrt_4G/source/master/build_dir/target-mipsel_24kc_musl/root-ramips/usr/lib/lua/luci/controller/admin/status.lua
But that file is already provided by package * luci-mod-status
* check_data_file_clashes: Package luci-mod-admin-full wants to install file /opt/svnworking/A1905_Openwrt_4G/source/master/build_dir/target-mipsel_24kc_musl/root-ramips/usr/lib/lua/luci/controller/admin/system.lua
But that file is already provided by package * luci-mod-system
* check_data_file_clashes: Package luci-mod-admin-full wants to install file /opt/svnworking/A1905_Openwrt_4G/source/master/build_dir/target-mipsel_24kc_musl/root-ramips/usr/lib/lua/luci/controller/admin/uci.lua
But that file is already provided by package * luci-base
* opkg_install_cmd: Cannot install package luci.
* check_data_file_clashes: Package luci-mod-admin-full wants to install file /opt/svnworking/A1905_Openwrt_4G/source/master/build_dir/target-mipsel_24kc_musl/root-ramips/usr/lib/lua/luci/controller/admin/index.lua
But that file is already provided by package * luci-base
* check_data_file_clashes: Package luci-mod-admin-full wants to install file /opt/svnworking/A1905_Openwrt_4G/source/master/build_dir/target-mipsel_24kc_musl/root-ramips/usr/lib/lua/luci/controller/admin/network.lua
But that file is already provided by package * luci-mod-network
* check_data_file_clashes: Package luci-mod-admin-full wants to install file /opt/svnworking/A1905_Openwrt_4G/source/master/build_dir/target-mipsel_24kc_musl/root-ramips/usr/lib/lua/luci/controller/admin/status.lua
But that file is already provided by package * luci-mod-status
* check_data_file_clashes: Package luci-mod-admin-full wants to install file /opt/svnworking/A1905_Openwrt_4G/source/master/build_dir/target-mipsel_24kc_musl/root-ramips/usr/lib/lua/luci/controller/admin/system.lua
But that file is already provided by package * luci-mod-system
* check_data_file_clashes: Package luci-mod-admin-full wants to install file /opt/svnworking/A1905_Openwrt_4G/source/master/build_dir/target-mipsel_24kc_musl/root-ramips/usr/lib/lua/luci/controller/admin/uci.lua
But that file is already provided by package * luci-base
* opkg_install_cmd: Cannot install package luci-mod-admin-full.
make[2]: *** [package/install] Error 255
make[2]: Leaving directory `/opt/svnworking/A1905_Openwrt_4G/source/master'
make[1]: *** [/opt/svnworking/A1905_Openwrt_4G/source/master/staging_dir/target-mipsel_24kc_musl/stamp/.package_install] Error 2

解决方法:将feeds\luci\modules\luci-mod-admin-full里的luasrc 进行删除

如无特殊说明,解压密码均为:aisoa.cn

您可能感兴趣的文章

支付宝打赏支付宝打赏微信打赏微信打赏