2020
09-08

子进程已安装 post-installation 脚本返回了错误号是什么?dpkg: error processing oracle-java7-installer (--configure)错误

dpkg: error processing oracle-java7-installer (--configure)错误

安装Oracle-java7-installer失败后,再次重新安装后出现错误~~

dpkg: error processing oracle-java7-installer (--configure):  子进程已安装 post-installation 脚本 返回了错误号 1

索性执行

sudo apt-get install -f

我勒个去,问题依旧~

重新安装不行,修复也不行了,只能找谷歌了

最后的解决办法是:

sudo dpkg -l | grep oracle

找到后直接使用完全卸载命令卸载

sudo dpkg -P  XXX.deb

OK,搞定,重新安装即可

其他安装软件时遇到的问题

debian/ubuntu安装软件依赖冲突错误

这就分享出来,帮大家多一个选择的解决方案,当然不到万不得已请不要选择这个方法。

现在我们来看看这个依赖的冲突问题吧。

安装软件时提示的是什么错误信息呢?

安装的软件依赖的软件版本过低。

首先系统怎么知道依赖冲突呢?

应该是每个软件都写清楚了自己依赖哪些软件以及这些软件的最低版本.

那我们能不能手动修改这些依赖的软件的版本呢?

如果知道这些信息在哪里储存,那就可以修改了。

那这些信息在哪里储存呢?

貌似在/var/lib/dpkg/status这个文件里面。

debian/ubuntu安装软件依赖包冲突怎么办?

如无特殊说明,解压密码均为:aisoa.cn

您可能感兴趣的文章

支付宝打赏支付宝打赏微信打赏微信打赏