[N1盒子]Coreelec系统插件库无法连接问题Coreelec9.0、9.1版本插件库无法连接修复

2021-02-10
0评论
/
阅读
管理员

推荐下《N1刷Coreelec系统Docker搭建aria2和webUI》与本文无关

Coreelec 插件库无法连接问题解决方法

自从Coreelec升级到9.1系统后原来底版本的固件均发生了无法连接Coreelec官方库的问题

原因是官方库的地址变更了. 底版本的地址是固化在固件里的,导致不能获取新版本固件库

还有更严重的问题是9.1系统的PVR API更改,新库中的PVR插件均无法运行在9.0以下的固件中

现在就让我们排除这些问题

Coreelec9.0以下版本插件库无法连接修复方法

更新插件库地址

ssh登录到主机

复制官方插件文件目录repository.coreelec

路径为

/usr/share/kodi/addons/repository.coreelec

复制到此目录下.

/storage/.kodi/addons/

Coreelec系统插件库无法连接

用文本编辑器打开repository.coreelec文件夹内的addon.xml

原来插件库地址中9.0部分全部修改为9.1,保存修改

到此修改地址完成

Coreelec系统插件库无法连接

删除packages文件夹,此文件是之前下载插件的缓存目录

Coreelec系统插件库无法连接

重启盒子后在Koid界面中选中Coreelcec插件库选择更新

待更新完成后就能正常下载所需插件了

注意: 新插件库中的PVR插件无法兼容9.0以下版本固件

如果想继续使用现有固件,下载zip包手动安装

9.0插件下载地址如下:

https://relkai.coreelec.org/?dir=addons/9.0/Amlogic/arm

9.1以上版本插件库无法连接修复方法

首先查看固件中的地址是否为新地址

cat /usr/share/kodi/addons/repository.coreelec/addon.xml

Coreelec系统插件库无法连接

如果地址为9.0则需要按照上述方法修改

如果已经是9.1执行下面两行命令,之后在Kodi界面中更新一下插件即可

rm -rf /storage/.kodi/addons/packages
rm -rf /storage/.kodi/addons/repository.coreelec

到此连接插件库问题完美解决

本站附件分享,如附件失效,可以去找找看
诚通网盘附件百度网盘附件

赞助我
如果本文对你有帮助,那么请你赞助我,让我更有激情的写下去,帮助更多的人。
本站加入了Google AdSense,因为谷歌 AdSense 算是广告商里难得“有节操、有底线”的佼佼者,没有任何低俗、垃圾、恶心的广告,所有希望不要“一刀切”式的拦截广告

如无特殊说明,解压密码均为:aisoa.cn


干饭福利分享: 微信扫码领取“饿了么”抵用券↓↓↓↓↓↓↓↓↓↓

标签: coreelec
于2021-02-10发布